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Key Concepts
· Add raw data sets to the Data Sets Tree (bottom-left), or, add pre-calculated data to existing visualizations (see Workflow).
· The Data Sets Tree contains sets of one or more variables (variable sets); the structure of a variable set determines how it is analyzed.
· Create tables and other analyses using options in Ribbon > Insert or by dragging variables sets from the Data Sets Tree (bottom-left) onto the page.
· Press Ribbon > Home > New Page to create new pages. Drag and drop pages to organize documents. Folders are created by dragging pages onto other pages.
· Pages and other objects can be hidden from exports by selecting them and clicking Ribbon > Appearance > Hide.
· Arbitrary calculations are performed using Ribbon > Insert > R Outputs (see Extracting results from tables using R Outputs).
· Modify objects by clicking on them and either
· Directly manipulating them (e.g., moving or resizing them).
· Modifying more commonly used options in the Ribbon (top of the screen).
· Modifying options in the Object Inspector (right-side of the screen).
· Trace any calculation back to the original data by hovering over the data input and pressing the [image: ] that appears in the preview window.
· Use Ribbon > Export to publish the document as a web page, PDF, PowerPoint, or Excel file.
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	1. Plan your dashboard
	Create a detailed plan for the dashboard (e.g., by prototyping slides in PowerPoint). It should show all the pages you want to create and the layout on each of those pages.

	2. Design and layout
	(Optional) Get a graphic artist to create a color palette, style guide, and images as PNGs and JPEGs
Dashboard Design: Working with a Graphic Designer
(Optional) Perform more advanced customizations using via the CSS
Customizing Logos, Icons, CSS, HTML Headers, and Language in Displayr

	3. Create a document
	Log in to Displayr and click + Add New (If using in conjunction with Q, see Using Q Projects in Displayr) 
Add and modify text, shapes and images: Ribbon > Insert > Text and images and Appearance
Create folders by dragging pages on top of other pages

	4. Hook up visualizations to data: there are four flows
	Flow A: Type in data
· Ribbon > Insert > Visualization
· Object Inspector > Inputs > DATA SOURCE > Paste or type data  
	Flow B: Insert Pre-Calculated Tables
· Ribbon > Insert > Paste Table
· Extract results from tables using R Outputs
· Ribbon > Insert > Visualization
· Object Inspector > Inputs > DATA SOURCE: Outputs in ‘Pages’
	Flow C: Analyze imported data sets (raw data)
· + Add a data set
· Create a table (Tables)
· Extract results from tables using R Outputs
· Ribbon > Insert > Visualization
· Object Inspector > Inputs > DATA SOURCE: Outputs in ‘Pages’ or Variables in ‘Data’
	Flow D: Live updating
Either Flow B or Flow C, except with Updating with Revised Data


	5. Duplicate
	Create something, and press Home > Duplicate, and modify the input data. You can apply this to everything from a text box through to a whole report. 

	6. Export
	Ribbon > Export > Excel, PDF, Web Page
[bookmark: _GoBack]When exporting to a web page, the resulting dashboard is seen by the viewer in view mode.
Prevent items from being exported by selecting them and pressing Ribbon > Appearance > Hide

	7. Filters for clients
	Select the variables(s) in the Data Tree and click Insert > Utilities > Filtering > Create Filters from Selected Data

	8. Create navigation
	Set hyperlinks to text, shapes, images, and charts: Insert > Hyperlink 
Hide the navigation bar (pages) from view mode by clicking the bottom of Export > Web Page and checking Hide Navigation Pane

	9. User management
	Press [image: ] (top left of Displayr) > Company Settings, press Expand (only if this option is available at the bottom of the page), and + New User.
To allocate a license to a user, go to Licenses tab and press Professional user > Add (to buy a new license) or Professional user > Assign (to assign an existing license to that user).
To create groups of users (with access to different documents), press + New Group 
To assign user access to individual document, go to the Documents page, hover over your document and click Settings, then go to Properties and modify which use groups have access to the document (Authorized for…) and individual pages in the document (Set tab-based access to document)

	10. Updating with revised data
	A. Manual updating of a data set
Click on the data set in the Data Sets Tree, and press Update in the Object Inspector
	B. Manual updating of a table/
visual-ization
Click on the table or visualize-ation and click Object Inspector > Inputs > DATA SOURCE > Edit Data
	C. Automatic updating via SQL
Data Sets Tree > + Add a data set > SQL > specify Automatic-ally refresh every

	D. Automatic updating via URL
Data Sets Tree > + Add a data set > URL > specify Automatic-ally refresh every

	E. Automatic updating of R Outputs
Ribbon > Insert > R Output
	F. Automatic updating of R Outputs
Data Sets Tree > + Add a data set > R
	G. API
If you have program-ing skills, you can write code to update using the API

	11. 
	
	
	
	
	flipTime::UpdateEvery 
Automatically Updating R Outputs, R Variables, and R Data Sets
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	Tables 
Note that one of the main ways of modifying a table is to change the data in the table, and when this is done all other tables using the same data will also change (see Manipulating tables)
	Summary tables
	Drag dragging from the Data Sets Tree onto the page

	
	Crosstabs
	[image: ]Create crosstabs by dragging a variable set from the Data Sets Tree and releasing it on the Columns slot of an existing table

	
	Duplicate a table
	Ribbon > Home > Duplicate

	
	Changing the data
	Object Inspector > Inputs > DATA

	
	View additional statistics
	Object Inspector > Inputs > STATISTICS

	
	Multiway table (layers)
	Ribbon > Insert > More > Tables > Multiway Table

	
	Create lots of tables
	Ribbon > Insert > Report



	Manipulating tables 
If a table is created by dragging variables sets from the Data Sets Tree, the categories of the table can be manipulated by dragging and dropping, and the changes apply to all other analyses based on the variable sets.
	Merging categories
	Click on the row or column name on a table and drag [image: ], or, select all the categories to be merged and press Ribbon > Data Manipulation > Merge

	
	Creating NETs
	Select the categories and press the Ribbon > Data Manipulation > Create NET

	
	Sorting/Re-ordering categories
	Click on the row or column name on a table and drag [image: ], or, Ribbon > Data Manipulation > Sort

	
	Removing a category and/or rebasing
	Click on the variable set in the Data Sets Tree and press Object Inspector > Properties > DATA VALUES > Missing values

	
	Switch between % and averages as main statistics on a table
	Click on the variable set in the Data Sets Tree and change the Object Inspector > Properties > INPUTS > Structure (see Variable Set Structures)



	Weights and filters
Weights and filters can be applied to the entire project or to selected tables and plots.
Where visualizations and R Outputs are created from tables, weights need to be applied to the source table.

	Use existing variables as filters/weights
	Select the variable in the Data Sets Tree and press Object Inspector > Properties > GENERAL > Usable as a filter or Usable as a weight

	
	Create new weights or filters manually
	Ribbon > Insert > New Filter or New Weight 

	
	Apply weights and filters
	Weights and filters can be created and applied from the Inputs tab of the Object Inspector when a page, table, or other output is selected.

	
	Create complicated weights and filters
	Ribbon > Insert > New R/JavaScript (Variable) > Numeric and press Object Inspector > Properties > GENERAL > Usable as a filter 

	
	Apply filters and weights to an object
	Click on the object: Object Inspector > Inputs > WEIGHTS/FILTERS

	
	Show sample size on page
	Ribbon > Insert > More (Analysis) > Data > Sample Size Description

	
	[image: ]Linking filters to controls
	How to Connect Filters to a Combo Box (Control)
Combo Boxes (Controls) With Dynamic Lists in Displayr

	
	Weights and filters in R Code

	The filter variable is called QFilter and the weights can be used as either QPopulationWeight, which contains the raw weight, or QCalibratedWeight, which sums to the effect sample size computed using Kish’s approximation



	Extracting results from tables using R Outputs
R Outputs are general-purpose outputs, which can contain text, tables, and visualizations. Code is used to determine their contents.  
A common use case for R Outputs is to contain results from a larger table.
	Creating an R Output
	Ribbon > Insert > R Output, enter code in R CODE, and click Automatic

	
	Finding the name of a table
	Click on the table: Object Inspector > Properties > General > Name

	
	Extracting a value from a one-dimensional table
	For example, to extract the result for Males from a table containing gender data: table.Gender["Male"] or, if the males are in the second cell of the table: table.Gender[2]

	
	Extracting a value from a two-dimensional table
	For example, to extract the result for Males aged 35 to 44: table.Gender.by.Age["Male", "35 to 44"]

	
	Extracting ranges of data from a table
	For example, to extract the result for Males for columns 2 through 4: table.Gender.by.Age["Male", 2:4]



	Variables
Tables, visualizations, and analyses take variables and variable sets as inputs. A variable set is a set of one or more variables.
Displayr automatically groups variables into variable sets when data sets are imported.

	Split a variable set into individual variables
	Click on the variable set in the Data Sets Tree and press Ribbon > Data Manipulation > Split (Variables)

	
	Combine individual variables into a variable set
	Click on the variables in the Data Sets Tree and press Ribbon > Data Manipulation > Combine (Variables)

	
	Change the structure of a variable set
	Click on the variable set in the Data Sets Tree and press Object Inspector > Properties > INPUTS > Structure (see Variable Set Structures)

	
	Recode the values of a variable set (including missing values)
	Click on the variable and review Object Inspector > Properties > VALUES > Labels, Values, Missing Values

	
	Create a new variable
	Ribbon > Insert > New R or New JavaScript 

	
	Recode into a different variable
	Select the original variable and press Ribbon > Home > Duplicate and then see Recode the values of a variable set 

	
	Banding/categorizing a numeric variable
	Ribbon > Insert > New R (Variable) > Numeric Variable with R CODE of cut(VARIABLE.NAME, 2) to create two categories, then set Object Inspector > Properties INPUTS > Structure to Nominal
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[image: ]
	· When you are stuck, click on whatever you are trying to modify and:
· Click the Suggestions which pop up in the top right corner of the screen 
· Look around the Ribbon
· Look around the Object Inspector: it has multiple tabs and groups to be expanded

	
	· Read our wiki and our blog 

	
	· If writing R code, hover your mouse over code to see additional documentation, use google, and read the warnings and errors that appear above the Object Inspector

	
	· Click on any errors and warnings in the Pages Tree and the Data Set Tree

	
	· Contact us: support@displayr.com 



	
What to do when the data in a table looks wrong
	Check the sample size of a table
	When you create a table, the sample size is shown at the bottom of the page.
[image: ]

	
	                                                   
Check count and sample size
	Object Inspector > Inputs > STATISTICS > Cells > Count or Sample Size

	
	Check the variable set structure 
	Click on the input variables in the Data Sets Tree, and review Object Inspector > Properties > INPUTS > Structure (see Variable Set Structures)

	
	Check that the appropriate Filter and Weight have been applied
	Select the output, then check Object Inspector > Inputs > FILTERS & WEIGHT

	[bookmark: _Hlk497742051]
	Review the value attributes of the input variable(s)
	Click on the variable and review the options in Object Inspector > Properties > DATA VALUES

	
	View the raw data
	See Viewing raw data

	
	Review how the input variables have been constructed
	Click on the variable and review its R CODE or JAVASCRIPT CODE in the Object Inspector > Properties

	
	If using Q: In Q check that the correct Rules are applied and, try and remove the rules
	[image: ]If a rule has been applied, a pink Rules tab will appear at the bottom of the table. Control when applied using the Apply dropdowns

	
	If using Q: In Q, check if empty rows/columns are hidden (Q users only; in Q)
	[image: ]Check to see if            is depressed (this hides empty rows and columns)



	
What to do when a visualization looks wrong
	Check the source data
	Click on the visualization, hover over the data inputs (Object Inspector > Inputs > DATA SOURCE), and click the [image: ] to go to the input or inputs.
[image: ]

See What to do when the data in a table looks wrong

	
	View the data table
	Set Object Inspector > Inputs > OUTPUT > Chart type to Table

	
	Modify the data manipulation settings
	If the data table looks wrong, but the inputs look correct, check the settings in Object Inspector > Inputs > DATA MANIPULATION, ROW MANIPULATIONS, and COLUMN MANIPULATIONS



	Viewing raw data

	Viewing the raw data for a variable set
	Drag the variable onto the page, and in the Object Inspector set Inputs > DATA > Columns to RAW DATA 

	
	Seeing raw data for lots of variables in Excel
	1. Select Ribbon > Insert > More > Tables > Raw Data
2. Select the desired variables in Object Inspector > Inputs > Variables
3. Click Automatic.
4. Select Ribbon > Export > Excel
5. Click Export and open in Excel

	
	Viewing the raw data for multiple variables
	Insert > More (Analysis) > Tables > Raw Data and select the Variables and check Automatic
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When you create a table in Displayr from data stored in a data set, the way the table appears is determined by the structure of the variable set (group of variables). Each variable set is represented as a folder in the Data Sets Tree. Each structure is represented by an icon. Structures are set automatically when importing data and can be modified in the Object Inspector.  
	Structure
	Description
	Example

	[image: ]Text
	A single variable containing text (or, numeric data that is interpreted as text)
	What is your name? 	_____________

	[image: ]Nominal
	A single variable that contains unordered, mutually exclusive, and exhaustive categories (i.e., has a nominal measurement scale)
	Gender categories: Male, Female, Unknown

	[image: ]Ordinal
	A single variable that contains ordered, mutually exclusive, and exhaustive categories (i.e., has an ordinal measurement scale).
	Age categories: Under 18, 18 to 24, 25 to 29, 29 to 54, 54 or more

	[image: ]Numeric
	A numeric variable (i.e., interval or ratio scale).
	The amount of money in a bank account.

	[image: ]Date /Time
	A numeric variable where the values represent times and/or dates. It contains the number of milliseconds since 1/1/1970.
	What is your date of birth?
 ____ / ____ / 19____

	[image: ]Text – Multi
	A set of related text variables.
	First Name, Last Name, and Street Address

	[image: ]Binary – Multi

	A set of related nominal variables, where each value only takes two non-missing values (perhaps after merging categories).
	Which of the following have you bought in the past week?

 Coke	 Pepsi	 Fanta

	[image: ]Nominal – Multi
	Multiple related nominal variables.
	Which meal did you eat most recently at…
	           Breakfast     Lunch        Dinner
McDonald’s        			
Burger King			
Wendy’s				

	[image: ]Ordinal – Multi
	A set of related ordinal variables (The icon is the same as for Nominal – Multi.)
	Please rate your satisfaction with the following airlines:
	              Low	Med	High
United        		  	  
British Airways		  	  
Qantas	              		  	  

	[image: ]Number – Multi
	A set of related numeric variables measured on the same scale.
	Balance of Savings Account, Balance of Credit Card, Balance of Home Loan

	[image: ]Binary Multi – Grid[image: ]
	This is a generalization of a Binary – Multi, where the variables can be ordered in two dimensions. 
	Which of these brands are cool?
 Coke	 Pepsi 	 Fanta 
Which of these brands are young?
 Coke	 Pepsi	 Fanta
Which of these brands are sexy?
 Coke	 Pepsi	 Fanta

	[image: ]Number – Grid
	This is a generalization of a Number – Multi, where the variables can be ordered in two dimensions.
	In the past month, how many economy flights did you take on...
Qantas ___	 United ___	Delta ___
…and how many business class flights did you take on...
Qantas ___	 United ___	Delta ___

	[image: ]Ranking
	A set of related numeric variables that represent a ranking, where the highest number is most preferred, and ties are permitted.
	Rank the following brands according to how much you like them...
 Coke ____   Pepsi ____   Fanta ____

	[image: ]Binary – Multi 
(Compact)
	The same underlying data as Binary - Multi, except that is stored as a Nominal – Multi and the unique values correspond to underlying binary variables. For example, in data storing people’s car model ownership, rather than having a binary variable for each model of car, instead the first variable represents peoples first care, the second variable is for their second car, etc. This format should only be used to represent data where it provides massive data storage gains, as it is generally difficult to manipulate and cannot accommodate the notion of missing data well.

	ExperimentX

	This structure is used to represent the various types of experiments, from randomized experiments (''Fully randomized experiments'' through to ''Conjoint Analysis'' and ''Choice Modeling'')
	Which of these would you buy?
	Coke
$2.00
Can
	Pepsi
$4.20
Bottle
	Fanta
$3.20
Flask
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