How to Remove Personally Identifiable Information from a Data Set

From Displayr
Jump to: navigation, search

It is generally best practice to not store Personally Identifiable Information, like names and email addresses with survey data, particularly when you need to share the survey data with third parties. For a variety of reasons, this kind of information can end up in your data set and you may have cause to remove it. It is generally best to ask your data provider to remove this information before sending you a file for analysis (or ask them to send you a new file if you discover personal information after you've started working on the data), but you can also take steps to remove it yourself when that option is not available.

This page describes the steps that you can take to remove personal information from a data set that you are working on in Displayr.


When working in a data set with PII, you need to hide the variables, save a copy of the file, create a new version with Q Reader, then update your Displayr document with the new file. The steps are:

  1. Load the data file with the PII included in your document in Displayr.
  2. On the left side, in the Data Tree, select one of the PII variables.
  3. On the right side, in the Object Inspector, check the box in Properties > Hidden except in the data tree. Repeat this for all PII variables in your Data Set.
  4. Save the data set with the hidden variables down to a QPack. Force Displayr to save the version with the hidden variables by clicking Export > Embed > Update all.
  5. Go to the Document Settings.
  6. In Version History, click Download on the QPack with the most recent version number.
  7. Download and install Q Reader. To install Q Reader click here. Please note, a Windows machine is required to install.
  8. Start Q Reader and go to File > Data Sets > Add to Project > From File. Load the QPack saved in Step 6.
  9. Once loaded, go to Tools > Save Data as SPSS/CSV and save data out to an SPSS file.
  10. Back in the Displayr document, click on the name of the Data Set to update in the Data Tree. Use the Update button in the Object Inspector to update the data with the SPSS file.
  11. Click Export > Embed > Update All.
  12. Go to your Documents page.
  13. Click the Duplicate button for your document to make a new copy.
  14. Click the Delete button next to the old document to remove the version that had the PII.