Release Notes

From Displayr
Jump to: navigation, search

The changes in each new version of Displayr are listed below.

Thursday, September 24, 2020

  • The Suggest feature which provides suggestions for categories in Insert > Text Analysis > Semi-Automatic Categorization now runs faster for larger data sets (over 1000 cases).
  • The underlying algorithm for Insert > Text Analysis > Automatic Categorization > Unstructured Text, Insert > Text_Analysis > Advanced > Principal Components Analysis (Text) and Insert > Text Analysis > Semi-Automatic Categorization has been modified for better performance. This may result in differences in output such as generated categories, principal components and suggested categorizations.

Monday, September 21, 2020

  • Speed Improvements.
  • Bug fixes.

Monday, September 16, 2020

  • The varimax rotation algorithm for Insert > Text Analysis > Advanced > Principal Components Analysis (Text) has been modified to perform better with larger data sets. This may result in slight differences in output. Also the return object has been trimmed to have a small memory footprint.

Monday, September 14, 2020

  • Speed Improvements.
  • Bug fixes.

Friday, September 11, 2020

  • An update has been made to Text Analysis > Advanced > Create Term Document Matrix so that it accounts for ngrams in the Text Analysis Setup item. The output is now in a sparse matrix format of class dgCMatrix, which is more broadly used than the previous format.

Monday,September 7, 2020

  • New QScript Filtering > Text Box Filters is now available in the Insert > Filter menu. Similar to Filtering > Combo Box Filters, this makes it easy to create a filter based on multiple text variables, which can be updated via text boxes and applied to all selected tables, charts, and R Outputs.

Friday, September 4, 2020

  • Bug fixes.

Monday, August 31, 2020

  • Speed Improvements.
  • Bug fixes.

Thursday, August 27, 2020

Monday, August 24, 2020

  • The underlying algorithm for Insert > Text Analysis > Automatic Categorization > Unstructured Text, Insert > Text Analysis > Advanced > Principal Components Analysis (Text) and Insert > Text Analysis > Semi-Automatic Categorization has been modified to perform better with larger data sets. This may result in differences in output such as generated categories, principal components and suggested categorizations.

Friday, August 21, 2020

  • Annotations can now be added to the data labels of Insert > Visualization > Line Chart, based on other statistics in the input table.
  • Bug fix
  • The minimum frequency option for Insert > Text Analysis > Advanced > Setup Text Analysis now defaults to scale minimum frequency as a percentage of cases. There is still the option to specify the minimum frequency as a fixed number.

Thursday, August 20, 2020

  • Speed improvements
  • Bug fixes.
  • Several features in the Analysis group of the Insert tab, including all items in Insert > Dimension Reduction, Insert > Regression, Insert > Segments, and Insert > Visualization now use the Value Attributes of categorical Variable Sets when converting them to numeric values.

Wednesday, August 19, 2020

  • New QScript Filtering > Combo Box Filters is now available in the Insert > Filter menu. Very similar to Filtering > List Box Filters, this makes it easy to create a filter based on multiple categorical variables, which can be updated via combo boxes and applied to all selected tables and charts.

Tuesday, August 18, 2020

  • The default behavior with unordered categorical variables for Insert > Dimension Reduction -- PCA, Scatterplot t-SNE, and MDS -- has changed to not create binary variables. To use the old default with new outputs, simply select the Check Box Create binary variables from unordered categories.

Wednesday, August 12, 2020

  • Fix made to Insert > More > Tables > Merge Two Tables and Merge Two or More Tables, so that merging a text and numeric table does not convert the numeric columns to text.

Thursday, August 13, 2020

  • Bug fixes.

Wednesday, August 5, 2020

  • Speed improvements
  • Bug fixes.

Tuesday, August 4, 2020

  • Bug fix.

Monday, July 27, 2020

  • Speed improvements
  • Bug fixes.

Friday, July 24, 2020

  • Insert > Visualization > Scatterplot has new option to use category labels instead of values so that row or span labels can be used in the X coordinates, Y coordinates, Sizes or Colors variable.

Thursday, July 16, 2020

  • Bug fixes.

Wednesday, July 15, 2020

  • Displayr now allows you to organize your Documents page into folders. Documents can be created within a folder by using the action buttons to the right of a created folder. Documents and folders can be moved between folders by selecting the action buttons to the right of the document or folder to be moved.
  • Removed duplicate filtering menu items from Insert > Utilities and removed redundant Filtering submenu group in Insert > Filter, so that filtering features are simply available from Insert > Filter.
  • Bug fixes.

Tuesday, July 7, 2020

  • Data from Decipher can now be imported using Add a data set
  • Bug fixes.

Monday, July 6, 2020

  • Added new option to some items in Insert > Visualization, to turn off the option to automatically expand margins. This can help with lining up multiple charts on the same page.

Wednesday, June 20, 2020

  • QScripts in the Insert > Transform menu will now show a list of applicable variable sets which the user can select from when no variable sets are pre-selected.

Monday, June 29, 2020

  • Bug fixes.

Friday, June 19, 2020

  • Added new controls to the relevant Text Analysis suite of functions to limit the number of levels and variables per case to save for the saved variable output for categories and first category in Insert > Text Analysis > Advanced > Save Variable(s) > Categories/First Category respectively. These are two new controls that limit the number of unique levels in the categorical output variable and the number of saved variables per case. The new controls exist in the Insert > Text Analysis > Automatic Categorization > List of Items & Entity Extraction outputs and Insert > Text Analysis > Advanced > Setup Text Analysis R outputs.

Thursday, June 18, 2020

  • Bug fixes.

Friday, June 12, 2020

  • QScript Filtering > Filter One Question by Another Question is now available in the Insert > Filter menu.

Wednesday, June 10, 2020

  • You can now choose to require stronger passwords for users of your company. Tick the check box under Account Settings>Settings to require all user passwords to be at least 8 characters long and include at least one each of upper case letters, lower case letters, numbers, other characters. All users will be prompted to change their password.
  • Bug fixes.

Wednesday, June 3, 2020

  • New QScript Filtering > List Box Filters is now available in the Insert > Filter menu. This makes it easy to create a filter based on multiple categorical variables, which can be updated via list boxes and applied to all selected tables and charts.

Tuesday, June 2, 2020

  • Bug fixes

Thursday, May 28, 2020

  • Bug fixes

Friday, May 22, 2020

  • Bug fixes
  • Shortened names of variables generated by the Save Variable(s) functions as well as various other functions that save variables with a name containing a random string. The names now simply consist of a short prefix and indices when there are multiple variables or naming conflicts with existing variables.

Wednesday, May 20, 2020

  • Bug fixes
  • Choice simulators have received a number of enhancements. There are new GUI controls in the created simulator, which allow for using filters and weights, scaling and calibrating to market share, applying different rules for calculating the preference shares, and filtering respondents for each alternative based on availability. Additionally, simulators can now be created with the 'None' alternative excluded and with the Alternative attribute (i.e. the alternative-specific constants) removed.
  • Choice optimizers can now be created for choice models. They have a similar appearance to our choice simulators, but by supporting multiple selection in the combo boxes of the simulator, multiple scenarios can be tested at once, allowing for portfolio optimization. They can be created by clicking the extension button Choice optimizer under the Simulation group in the Object Inspector of any output from Hierarchical Bayes, Latent Class Analysis, and Multinomial Logit. Choice optimizers have all the same enhancements listed above for simulators.

Monday, May 18, 2020

  • Added the following extension button that appears in the Inputs tab when selecting a Principal Components Analysis or Principal Components Output (Text) output: Component Plot.
  • Added the following extension button that appears in the Inputs tab when selecting a Choice Modelling output: Utilities Plot.

Wednesday, May 13, 2020

  • Bug fix
  • Modified arrow symbols used in Insert > Segments > Segment Comparison Table to improve visibility.
  • Random number changes in Insert > Machine Learning > Deep Learning outputs due to an update in Tensorflow to version 2.2.0.
  • Fixed beta.draws property in choice model outputs so that draws for numeric variables in beta.draws are correctly scaled. Also prefixed the term "Scaled" to numeric variable names in Parameter statistics table (hierarchical Bayes only), Posterior intervals plot and Trace plots outputs as they have been scaled by a multiplicative factor for modeling purposes.
  • Added random seed option to Choice Model and MaxDiff Standard R outputs which allows for different random starting parameters for the model and different questions to be left out for cross-validation.
  • Added "Number of starts" option to Choice Model and MaxDiff latent class analysis outputs which allows the model to be run multiple times with different starting parameters and the model with the best log-likelihood is selected as the final model.

Tuesday, May 12, 2020

Wednesday, May 6, 2020

  • Bug fix

Tuesday, May 5, 2020

  • Bug fix
  • Added the following action buttons that appear in the Inputs tab when selecting a hierarchical Bayes, latent class analysis or multinomial logit choice model output: Save individual-level coefficients, Save proportion of correct predictions, Save RLH, Save utilities (mean = 0), Save utilities (mean = 0, max range = 100), Save utilities (mean = 0, max range = 100), Save utilities (min = 0), Save utilities (min = 0, max range = 100), Save utilities (min = 0, mean range = 100), Parameter statistics table.
  • Added the following extension buttons that appear in the Inputs tab when selecting a latent class analysis choice model output: Save class membership probabilities, Save class membership.
  • Added the following extension button that appears in the Inputs tab when selecting a principal components analysis, multiple correspondence analysis or t-SNE output: Save transformed variables.
  • Added the following extension buttons that appear in the Inputs tab when selecting a linear discriminant analysis output: Save discriminant variables.
  • Added the following extension buttons that appear in the Inputs tab when selecting a machine learning output: Save predicted values, Save predicted probabilities.
  • Added the following extension buttons that appear in the Inputs tab when selecting a hierarchical Bayes, latent class analysis or multinomial logit MaxDiff output: Save preference shares, Save Sawtooth preference shares, Save zero-centered utilities, Save individual-level coefficients, Save proportion correct, Save root likelihood (RLH).
  • Added the following extension buttons that appear in the Inputs tab when selecting a latent class analysis MaxDiff output: Save class membership probabilities, Save class membership.
  • Added the following extension buttons that appear in the Inputs tab when selecting a regression output: Save fitted values, Save predicted values, Save residuals.
  • Added the following extension button that appears in the Inputs tab when selecting a k-means cluster analysis output: Save segment membership.
  • Added the following extension buttons that appear in the Inputs tab when selecting a text analysis output: Save categories, Save first category.
  • Added the following extension buttons that appear in the Inputs tab when selecting a Insert > Text Analysis > Advanced > Setup Text Analysis output: Save tidied text, Save sentiment scores.
  • Added the following extension buttons that appear in the Inputs tab when selecting a choice model experimental design: Balances and overlaps, Numeric design, Standard errors.
  • Added the following extension button that appears in the Inputs tab when selecting a latent class analysis choice model output: Class Parameters.
  • Added the following extension buttons that appear in the Inputs tab when selecting a hierarchical Bayes choice model output: Posterior intervals plot, Trace plots.
  • Added the following extension button that appear in the Inputs tab when selecting a correspondence analysis of a table: Quality table.
  • Added the following extension button that appear in the Inputs tab when selecting a linear discriminant analysis: Coefficients of discriminant functions.
  • Added the following extension button that appear in the Inputs tab when selecting a machine learning output: Prediction-accuracy table.
  • Added the following extension button that appear in the Inputs tab when selecting a MaxDiff output: Parameter statistics table.
  • Added the following extension buttons that appear in the Inputs tab when selecting a latent class MaxDiff output: Class parameters table, Class preference shares table.
  • Added the following extension buttons that appear in the Inputs tab when selecting a hierarchical Bayes MaxDiff output: Posterior intervals plot, Trace plots.
  • Added the following extension buttons that appear in the Inputs tab when selecting a regression model output (not all buttons apply to all regression types): Residual heteroscedasticity test, Multicollinearity (VIF) table, Residual normality (Shapiro-Wilk) test, Cook's distance plot, Cook's distance vs leverage plot, Influence index plot, Normal Q-Q plot, Residuals vs fitted plot, Residuals vs leverage plot, Scale-location plot, Prediction-accuracy table, Serial correlation (Durbin-Watson) test.

Monday, May 4, 2020

  • Fixed error in handling of missing values when computing Percentages of variables in Insert > Visualization > Number and Insert > Visualization > Pictograph > Single Icon.
  • Values Axis > Minimum value now adjustable in Insert > Visualization > Radar Chart.
  • New relative importance output options of Jaccard Coefficient and Correlation available in Insert > Regression > Driver Analysis (when output type is Linear Regression) and in Insert > Regression > Linear Regression

Tuesday, April 29, 2020

  • Text variable sets can now be translated to another language by selecting one and clicking on the Language translation button under the TRANSFORMATIONS group in the object inspector. Alternatively, they can be translated by selecting them and clicking on Insert > Transform > Translate or Insert > Utilities > Create New Variables > Translate.

Tuesday, April 28, 2020

  • Bug fix

Monday, April 27, 2020

  • Bug fixes

Tuesday, April 21, 2020

  • The order of Row and Column manipulations in Visualizations has been modified to make it easier to apply multiple operations on an input table. The operations are now performed in the following order: Hide empty rows/columns, Hide rows/columns with small sample sizes, Rows/Columns to show, Sort rows/columns, Order rows/columns by similarity, Rows/Columns to ignore, Number of rows/columns from top/left to show, Number of rows/columns from from bottom/right to show.

Tuesday, April 20, 2020

  • New transformation QScripts are available in Insert > Transform > Scale Within Case and Insert > Transform > Scale Within Variable. The QScripts formerly available as Rank Within Variable, Rank Within Case, and Standardize Data by Case have been moved to these submenus. The new QScripts are 1) Standarize , which transforms data to have mean 0 and standard deviation 1, 2) Center, which transforms data to have mean 0, and 3) Unit, which transforms data to have minimum 0 and maximum 1. The transformations can also be performed by selecting a variable set from the Data Tree and clicking the corresponding button under ACTIONS in the Object Inspector.

Friday, April 17, 2020

  • There’s a new design to the top bit of the screen, which will make it easier to switch between settings, view, documents, and edit mode.
  • We have tightened security around password rules, login, and logout functions.
  • Other bug fixes, including issues affecting the Find/Replace feature.

Wednesday, April 15, 2020

  • Segments > Segment Comparison Table has new option to display significant values using Shade Bars.

Tuesday, April 7 2020

  • Insert > Regression > Driver Analysis added to the menu to facilitate quick driver analysis options and data stacking.

Monday, April 6, 2020

  • Shortcut keys have been added for navigation in View mode.
    • To jump to the next slide, press the space bar, PageDown, Enter, N or the down or right arrow.
    • To jump to the previous slide, press Backspace, PageUp, P or the up or left arrow.
  • Bug fixes

Friday, April 3, 2020

  • Insert > Visualization > Line Chart now has the option to show data labels and markers at the end points of each data series only.

Wednesday, April 1, 2020

  • Segments > Segment Comparison Table now has options to shade font colors and arrows to display significant values. These output options are now available in Segments > K-Means Cluster Analysis when the output type is Segment profiling table.
  • Text Analysis > Advanced > Principal Components Analysis (Text) added to the menu allowing the option to analyze text data by conducting a PCA via a numeric text encoding. The correlation of the PCA scores with a type of document term matrix is used to help interpretation and a varimax type rotation is conducted by default to help facilitate the interpretation (the rotation can be not conducted if desired).

Friday, March 27, 2020

  • Two new QScripts are available in Insert > Transform > Modifying Data: Modifying Data - Create New Top K Category NETs (That is, Top K Boxes) and Modifying Data - Create New Bottom K Category NETs (That is, Bottom K Boxes), which allow for creating new NET categories in Nominal and Nominal - Multi variable sets.

Thursday, March 19, 2020

  • Bug fixes.

Tuesday, March 17, 2020

  • Added Output language control to Insert > Text Analysis - Automatic Categorization > Unstructured Text which allows categories and example text in the output to be shown in languages other than English.

Friday, March 13, 2020

  • Bug fixes.

Friday, March 6, 2020

  • Bug fixes.
  • Implemented the dummy variable adjustment technique for missing data in Insert > Regression > Linear Regression and the other regression types. It is accessible through the Missing data dropbox for all relevant regression types.

Friday, February 28, 2020

  • Insert > Visualization > Scatterplot has been updated so that Row/column manipulations are applied to the input table in the same way as other visualizations when Input data contains y-values in multiple columns is selected.

Thursday, February 27, 2020

  • Changes you make in Text Analysis will periodically be saved automatically.
  • You can now select and copy text from warnings and messages in the object inspector, to help with finding a resolution.
  • Bug fixes

Wednesday, February 19, 2020

  • Bug fixes.

Wednesday, February 19, 2020

  • More formatting options for secondary data series (shown as lines) has been added to Column Chart visualizations

Thursday, February 13, 2020

  • Bug fixes.

Thursday, February 13, 2020

  • Insert>Regression>Linear Regression and the other six regression types now have an automated outlier removal option. The new input control is called Automated Outlier Removal Percentage and accepts a numeric value between 0 and 50 (including 0 but not 50). If a non-zero value is selected for this option then the regression model is fitted twice. The first regression model uses the entire dataset (after filters have been applied) and identifies the observations that generate the largest residuals. The user specified percent of data values that have the largest residuals are removed from the data. The regression model is refitted on this reduced dataset and output returned. If a zero-value is selected for this input control then no outlier removal is performed and a standard regression output for the entire (filtered) dataset is applied.

Wednesday, February 12, 2020

  • Added support for text data in languages other than English in Insert > Text Analysis - Automatic Categorization > Unstructured Text through the new Source language control.

Tuesday, February 11, 2020

  • Bug fix.

Monday, February 10, 2020

  • Scatterplot visualizations now has the option of adding annotations.

Wednesday, February 5, 2020

  • The time taken for R variable calculations is now shown in Object Inspector>Inputs>Time to load.
  • Document Settings>Version History will now show a user name for someone who has clicked Export to Web, Republish, or been the only person making changes to the project. If more than one person has been making changes the Last modified by column will show "(multiple users)".
  • Bug fixes.

Friday, January 31, 2020

  • Bug fixes.

Thursday, January 30, 2020

  • In Visualization outputs, the result when multiple Row/column manipulation options are used has been changed. Number of rows/columns from top/bottom/left/right is now applied after Rows/Columns to show. For example, you can now specify a long list of variables to show using Columns to show, and then specify that only the first 3 of the columns selected should be shown, without using an intermediate table.

Thursday, January 23, 2020

  • Interactive tutorials have been added to the Documents page as additional projects.
  • Bug fixes.

Wednesday, January 22, 2020

  • Added new item in Marketing > Price Sensitivity Meter.

Monday, January 20, 2020

  • Insert > Text Analysis > Automatic Categorization > List of Items and Insert > Text Analysis > Advanced > Setup Text Analysis now default to counting frequency by number of respondents instead of occurrences in the input text.

Friday, January 17, 2020

  • Bug fixes

Tuesday, January 14, 2020

  • Insert > Visualizations > Scatterplot now able to handle Regression output in the X coordinate and Y coordinate input area. The values in the plot are either the regression coefficients or importance scores respectively depending on the Regression settings.

Thursday, January 9, 2020

  • Bug fixes

Tuesday, January 7, 2020

  • Annotations can now be added to the data labels in Insert > Visualizations > Bar Chart and Insert > Visualizations > Column Chart, based on other statistics in the input table.

Thursday, December 19, 2019

  • Users can now download an audit trail CSV file of security-related actions such as creating, opening and deleting documents; downloading documents; adding and removing users; and modifying user groups. Account>Usage>Audit Trail.
  • Bug fixes

Tuesday, December 17, 2019

  • Tick labels in Scatterplots with categorical axis are now ordered according to the order they appear in input table (instead of alphabetically).
  • Regression outputs with imputated values may have small changes due to an upgrade to mice version 3.7.0.

Thursday, December 12, 2019

  • Bug fixes

Thursday, December 5, 2019

  • Shapley Regression available for Insert > Regression > Linear Regression.

Tuesday, December 3, 2019

  • It is now possible to add Controls to Master pages.
  • Bug fixes

Friday, November 29, 2019

  • You can now export reports on a loop using filters selected in View Mode under Export>PowerPoint>Advanced Options, Export>Excel>Advanced Options, and Export>PDF>Advanced Options.
  • Bug fixes

Tuesday, November 26, 2019

  • The Text Analysis coding window will now be sized to use the full available space on your page.
  • Bug fixes

Friday, November 22, 2019

  • Added support for Insert > Text Analysis > Advanced > Save Variable(s) - First Category/Categories to handle Text Analysis > Advanced > Setup Text Analysis output and Text Analysis > Automatic Categorization > Unstructured Text with a multiple response Existing Categorization.

Wednesday, November 20, 2019

  • Bug fixes

Thursday, November 14, 2019

  • Raw text replacement and Category replacement options in Insert > Text Analysis > Automatic Categorization > List of Items has been replaced by the Required categories (variants can now be specified) and Split into categories option.
  • Variant suggestions for Required categories are now shown in the diagnostics output for Insert > Text Analysis > Automatic Categorization > List of Items.

Wednesday, November 13, 2019

  • Errors in Independent Complex Samples t-Test / z-Test:
    1. Column Comparisons report statistically significant differences between values which are identically 100.
    2. Where the user has chosen to apply a z-Test to test means on this table (Edit > Project Options > Customize > Statistical Assumptions > Statistical Tests for categorical and numeric data > Means > z-Test), but when using the 'alpha' button to test significance the output is providing a link to the t-Test version of the complex samples test for means.
  • Bug fixes

Tuesday, November 5, 2019

  • The standard error shown on tables of correlations was computed using (1 - R2)/sqrt(n - 1). This is not correct. It now is computed using sqrt((1-R2)/(n-2)). The statistical tests were using the correct formula, so no change has occurred in terms of which results are flagged as significant.
  • On summaries of numeric variables, the standard deviations and associated statistics (standard errors and statistical tests) had an error in them whereby they failed to take missing values into account. If a study has extremely high rates of missing data these may have caused non-trivial differences. This only affected summary tables; not any crosstabs.
  • Bug fixes

Tuesday, October 29, 2019

  • Bug fixes
  • Changed handling of missing values in Insert > Visualizations > Pie Chart to be consistent with other visualizations.

Wednesday, October 28, 2019

  • Added Text Analysis > Automatic Categorization > Entity Extraction which automatically extracts Named Entities from a text variable
  • Added support to Insert > More > Marketing > MaxDiff > Hierarchical Bayes, Insert > More > Marketing > Marketing > MaxDiff > Latent Class Analysis, and Insert > More > Marketing > Marketing > MaxDiff > Multinomial Logit for handling best and worst choices that are supplied as the displayed option (e.g. the values 1,2,..., up to the number of alternatives per question) instead of as the selected alternative.

Wednesday, October 23, 2019

  • Bug fixes

Friday, October 18, 2019

  • Bug fixes

Thursday, October 10, 2019

  • Added Binary transformation for Numeric and Categorical data in Insert > Transform > Binary
  • Added Log based transformations in Insert > Transform > Log
  • Added Square-root and power based transformations in Insert > Transform > Square-root
  • Added statistical rank transformations in Insert > Transform > Rank Within Case and Insert > Transform > Rank Within Variable

Tuesday, October 8, 2019

  • Text editing has been updated, including adding options for line and paragraph spacing. This may cause changes to line height in existing text boxes with small font sizes.
  • Bug fixes

Tuesday, October 1, 2019

  • Added "Existing categorization" option to Insert > Text Analysis > Automatic Categorization > Unstructured Text which allows an existing categorization to be used by the categorization algorithm.
  • Added support for identifying n-grams in Insert > Text Analysis > Advanced > Setup Text Analysis.

Friday, September 27, 2019

  • Bug fixes
  • Added new option Autofit to Insert > Enter Table for table to fill the container (without scroll-bars).
  • Added new option in Insert > Visualization > Column Chart to add additional data series as lines with a second Y axis that can be customized separately from the primary Y axis.

Tuesday, September 24, 2019

  • The user interface has had a design refresh
  • Please see Insert > Link for new link options which can be embedded in items in your project.
  • Bug fixes and speed improvements

Monday, September 16, 2019

  • Bug fixes

Tuesday, September 10, 2019

  • Added Insert > Text Analysis > Automatic Categorization > Unstructured Text which automatically codes a text variable containing unstructured text into categories.

Friday, September 6, 2019

  • Bug fixes

Wednesday, August 28, 2019

  • Bug fixes

Tuesday, August 20, 2019

  • Bug fixes

Tuesday, August 13, 2019

  • Bug fixes
  • List categorization (Insert > More > Text Analysis > Automatic Categorization > List of Items) now shows diagnostics information at the bottom of the output.

Friday, August 8, 2019

  • Lots of Crosstabs (Insert > Tables > Lots of Crosstabs) allows you to quickly create tables/crosstabs of many variables and optionally to sort the tables based on their most significant p-values and exclude tables that do not contain a single p-value below a selected cut-off.

Wednesday, August 6, 2019

  • Brand health tables (Insert > More > Marketing > Brand Health Table)

Friday, August 2, 2019

  • Bug fixes

Thursday, July 25, 2019

Monday, July 22, 2019

  • Bug fixes

Friday, July 12, 2019

  • Bug fixes

Monday, July 1, 2019

  • Bug fixes

Wednesday, June 26, 2019

  • Data shown in view mode for a dashboard can be filtered based on the viewer's login, using the user groups in Account > Settings > Groups and an R variable. See User Groups for more detail.
  • You can now create new Master Pages by duplicating existing ones, and the masters can also be re-ordered and deleted.
  • Bug fixes

Tuesday, June 18, 2019

Export Changes

  • We’ve (hopefully) made Export > Web Page and Export > Embed much easier to use.
  • You can now get the data from any output into your clipboard using Export > Copy Data.

Other Changes

  • Minor bug fixes.

Monday, June 17, 2019

  • Text coding of open-ended responses and other text data may now be performed by selecting the Text variable under Data Sets and clicking Insert > Variables > New Text Analysis > New Code Frame. For more info, see Coding.
  • Users can now copy items from one Displayr browser tab to another.
  • Bug fixes

Tuesday, June 11, 2019

  • Sampling weights cab be created: Insert > More > Weighting > Create Weight
  • Variable transformation can now be performed using the drop downs in Insert > Variables > Transformation or Data Manipulation > Variables > Transformation.
  • Banner functionality has been extended by having Drop boxes (e.g. a Table's Rows/Columns) in the object inspector turn into a banner palette when users drag variable set onto them. If the user drops a variable set alongside existing data, this automatically creates a banner in the background and selects it on the table/chart/etc.
  • Bug fixes.

Monday, June 3, 2019

  • Bug fixes

Friday, May 31, 2019

  • Bug fixes

Thursday, May 23, 2019

  • Bug fixes

Friday, May 17, 2019

  • Banners can now be created by selecting a Variable Set under Data Sets to use as initial data, and clicking on Insert > Variable > Banner in the ribbon. This creates a new Banner variable set in Data Sets. This variable set can be used in tables, charts, etc in the same way as other variable sets, to include the banner in the end product. The Banner variable set can be edited and expanded by selecting it in Data Sets and using the Object Inspector.
  • Bug fixes

Thursday, May 9, 2019

  • Bug fixes

Friday, May 3, 2019

  • Bug fixes

Friday, April 26, 2019

  • Bug fixes

Wednesday, April 19, 2019

  • Bug fixes

Thursday, April 11, 2019

  • Bug fixes

Monday, April 1, 2019

Features

  • Textbox and List Box options have been added to Insert>More>Controls.

Bug Fixes

  • Correction allowing weights to be used in Explore mode without triggering an error.
  • Blank pages are no longer included in exported PDF's in place of hidden pages.
  • Minor fixes.

Thursday, March 21, 2019

  • Bug fixes

Wednesday, March 20, 2019

  • Various bug fixes, including correcting the interaction between date controls and linked ROutputs.

Friday, March 15, 2019

  • You can now download more detailed information about the actions users are making when editing or viewing your documents from your Account page.
  • When exporting tables to Excel, you may now choose to have the results of the Column Comparisons statistical testing shown on a separate row to the other statistics in the table.
  • Various small improvements and bug fixes, including improved support for custom monitor scaling and handling of invalid files selected for data set input.

Monday, March 4, 2019

Thursday, February 14, 2019

  • Added the ability to change the default colors for charts and tables, and color palettes for charts, tables, callouts, and shapes. This is done in the Page Master, see Setting the Default Colors for Charts and Tables for more details.
  • Re-size multiple selected objects on a page.
  • If a filter or weight is applied to an R calculation that uses variables from different data sets, then there must be a relationship defined between those data sets. The filter/weight will be resized to suit the joined data. Note that we do not yet join the other input variables, but may in future.
  • Bug fixes.

Monday, February 4, 2019

  • Enables exporting of larger projects from Displayr to PDF, PowerPoint, and Excel.

Monday, February 4, 2019

  • Bug fixes

Tuesday, January 29, 2019

We’ve made lots of small tweaks, including:

  • You can now create documents of the same dimensions as the modern, widescreen PowerPoint layout: Home > Layout > Page Size > Widescreen (16:9)
  • Lots of little fixes/tweaks to filtering.
  • WordClouds should now export WYSIWIG.

Friday, January 18, 2019

  • When specifying a range of dates in the Date/Time settings for a Date variable, the minimum and maximum will now default to the start and end of the days in the range.
  • Hyperlinks can now be set in Page Master on text and image objects.
  • Banners can now be deleted.
  • Other bugs and feature enhancements.

Friday, January 4, 2019

  • Support can now provide a branded sub domain for you: [your name].Displayr.Com. Please contact support if you wish to make use of this feature.
  • Server hours for private dashboards can now be purchased in lots of 100 at $2/hour.
  • Bug fixes

Tuesday, December 18, 2018

  • If a filter or weight is applied to an R calculation that uses variables from different data sets, then there must be a relationship defined between those data sets. The filter/weight will be resized to suit the joined data. Note that we do not yet join the other input variables, but may in future.
  • An option has been added to the Appearance ribbon, in the Show section, to allow users to set up guides to help align objects across different pages.
  • A button has been added to the Documents page to allow the user to view published dashboards of a highlighted document.
  • A 16:9 widescreen page size option has been added under Home>Page Layout>Layout>Page Size
  • Users can now add more than one cc email address for billing in the Billing details section of the Settings page for their company. Enter the email addresses in the User/CC email: field, separated by a comma.
  • Bug fixes

Tuesday, December 4, 2018

  • In addition to adding custom colors to the Color Selector in Displayr, the user can now edit or delete them. Right click on an existing custom color at the bottom of any color selector to get the edit and delete options for that color. Any changes made will affect the custom colors available in all Color Selectors for the project. Please note that change or deletion of a custom color will not be automatically propagated to objects where it has been used. These will retain the old custom color until changed by the user.
  • While in edit mode, a user will now be able to see when other users are editing the same project. The initials of any other users will be displayed in the Pages tree, next to the page they are accessing. Hovering the cursor over the initials will show a tool-tip with the username of the other user.
  • The user can now select multiple objects on a page and use the Appearance section of the Object Inspector to make changes in common for them. Any change made in the Appearance section will be applied to all currently selected objects which use that appearance control.
  • An option has been added to the Paragraph section of the Appearance ribbon controls which allows the user to whether a textbox will automatically resize to fit the text entered, or not.
  • Bug fixes

Monday, November 26, 2018

  • Bug fixes

Monday, November 19, 2018

  • Freemium

Displayr has moved to a new Freemium pricing structure. Users can access Displayr under a free licence with up to 20 free documents. These documents cannot:

    • Use any export options other than to a Public Web page.
    • Use data sets of more than 1,000 rows or 100 columns.

In addition, Free users cannot access the Company or Document Settings pages. If a user on a Free licence tries to access a feature requiring a paid licence, or a free document is changed in a way which is not allowed for a Free document, the user will be invited to upgrade to a Professional licence. If a free trial of a Professional licence, with 10 server hours, will be available.

  • Minor bug fixes

Thursday, November 15, 2018

  • Bug fixes.

Tuesday, November 6, 2018

  • Minor bug fixes.

Friday, November 2, 2018

  • Settings added to Controls to allow the user to determine their behavior when the control’s R item list changes.
  • Minor bug fixes.

Wednesday, October 31, 2018

  • Minor bug fix.

Tuesday, October 30, 2018

Hiding filters from View Mode

A user can hide filters they use in Edit mode from being seen in View mode. Select the variable in Edit mode, and check the Hidden except in data tree box in Object Inspector>Properties.

HideFilters.png

Other items

  • Further speed enhancements
  • Minor bug fixes

Monday, October 29, 2018

  • Speed improvements

Friday, October 26, 2018

  • Speed improvements
  • Security updates
  • Minor bug fixes

Thursday, October 25, 2018

  • Minor bug fixes.

Thursday, October 18, 2018

  • Controls which have been set to allow multiple selections now have a ‘select all’ option included.
  • Minor bug fixes.

Monday, October 15, 2018

  • Bug fixes and security updates.

Friday, October 5, 2018

  • Bug fixes

Wednesday, October 3, 2018

  • Dropdown control boxes can now use a selected R or table output to generate its list.
  • Bug fixes

Monday, September 24, 2018

  • Bug fixes and security updates.

Tuesday, September 18, 2018

  • Bug fixes and speed improvements
  • Huge .mdd files will now load in a reasonable amount of time

Wednesday, September 5, 2018

  • R GUI control group will expand if there is an issue with an input for the control.
  • Displayr now can only be accessed using browsers supporting TLS 1.1 or higher. See Displayr TLS support information
  • Bug fixes.

Wednesday, August 22, 2018

  • Improvements to suggestions. If you want to return suggestions that you might have closed in the past, click the icon next to your name in the top right and select Restore Previously Closed Suggestions.
  • Improved behavior for submenus in the Object Inspector.
  • The following buttons from the Data Values section of the Data Manipulation tab have been moved to the DATA VALUES section of Object Inspector options that are shown when you have a variable set selected:
    • Labels
    • Values
    • Select Categories
    • Missing Values
  • The Value Attributes button has been replaced with the buttons mentioned above.
  • The Delete Data button in the Data Values section of the Data Manipulation has been moved to the Object Inspector shown when a data set is selected. It has been renamed to Delete observations.
  • The styling of the Document Settings page has been given a facelift. All of the original options are found in one of the new subsections: Properties, Version History, Users with access, Other.
  • Displayr no longer allows insecure web browsers. This only affects old web browsers such as Internet Explorer 10 and workarounds are available (see our article Browsers That Do Not Support TLS 1.1).
  • Exports of R outputs are now limited to 6000 by 6000 pixels.
  • Improved support for touch-only devices.
  • More general performance improvements.

UIChanges22Aug18.PNG

Wednesday, July 25, 2018

  • Updated how R error messages are displayed in the Edit and View modes and in exported PDF, or PowerPoint documents.
  • Add Data Set button was renamed to New Data Set
  • If an Excel/CSV data set looks to contain tabular data (e.g. aggregated statistics) rather than raw data, the user will be given the option to instead add it as a table.
  • Bug Fixes.

Tuesday, July 4, 2018

  • A new, improved Documents page. Creating a new document is now done via the + Add new button. Uploading a document is now done via Upload > QPack, and uploading an Office document or PDF file is now done with Upload > Office / PDF.
  • The Utilities button has now been moved from the Data Manipulation tab to the Home tab.

Friday, June 20th, 2018

  • Bug Fixes

Friday, June 15th, 2018

  • Bug Fixes

Friday, June 8th, 2018

New Features/Changes:

  • Displayr now only supports browsers that are less than 3 years old: Chrome 42+, Firefox 38+, IE 9+, Safari 5+
  • Company admins can now see whether invited users clicked on the invitation link or not on the Setting page
  • Improved responsiveness when user opens the R dropbox with large number of variables/variable sets
  • Users can attach a screenshot to a Problem report
  • Filters and weights selection has been moved to Object Inspector's Inputs tab.
  • Updated Amazon Redshift driver from version 1.3.7 to 1.4.1 (AmazonRedshiftODBC64-1.4.1.1001.msi).
  • Bug Fixes

DataSelectionMove.png

Monday, April 30th, 2018

New Features/Changes:

  • Users can now specify the variable which will uniquely identify the case in the data set and delete cases specified by a filter.
  • Improved Shapes, including better compatibility with PowerPoint / PDF exporting.
  • Users can import their data directly from Qualtrics via the Qualtrics API.
  • Long-running R calculations should work with scheduled updates.
  • Scheduled updates in view mode can now run for up to 50 minutes.
  • The selected values of custom Controls can be seen in PDF and PowerPoint exports.
  • The Insert > Analysis section of the ribbon has been restructured to make segmentation, regression, machine learning, and dimension reduction tools easier to get to.
  • Splitting, combining, and duplicating variables no longer requires the user to interact with entire variable sets (you can work with any selection of variables.
  • Suggestions box wording change.
  • Bug fixes.


Thursday, March 15th, 2018

New Features/Changes:

  • File upload limit is removed from Displayr;
  • Restrict editing of per-company HTML in headers to only Displayr admin users;
  • Displayr users can now automatically generate reports from data using ribbon button;
  • View-mode usage notifications are only sent to company administrators;
  • New R output are staggered when added to the page, so they don't overlap;
  • Users can control how long a QServer runs before auto-stopping when idle;
  • User can switch between table/chart using object inspector buttons;
  • If user replies to Displayr invitation email it will go the company admins instead of Displayr admins;
  • Users can now see how long R calculations have being running by hovering over them;
  • "An error occurred when opening..." message has been made clearer;
  • Invoices now include licence details on invoices;
  • Long-running R calculations should work with scheduled updates;
  • Rename/Duplicate/Delete/Settings are now hidden for users that can only view documents.
  • Users with outstanding invitations to the company are now displayed separately on the Account page.

Bug fixes:

  • R Outputs and Table/Chart dropboxes now show names of Variables and Questions the same way;
  • Fix Displayr slowdown with large number of pages in Displayr;
  • Fix issues with shapes on master slides;
  • Fix shape transparencies in PowerPoint exports;
  • Fix R code highlighting;
  • Fix R item calculations when user performs undo/redo/refreshing data operations;
  • Fix copy R output to clipboard yields odd table;
  • Fix R item gives bug report when exported to Excel;
  • Fix R Outputs not automatically recomputing if variable's runtime error fixed;
  • R warnings sometimes appear twice;
  • Fix R plot drawn incompletely in Displayr;
  • Displayr will now retry retry scheduled R updates if they fail due to R errors;
  • Fix issue with deleting cases does not cause R outputs to become out of date;
  • Selection of items in multiselect drop-box is lost when R output is deselected;
  • Fix labels labels shown in New Filter window;
  • Fixed Moving Table with weight updates the weight;
  • Fix Editing page name causes table to reformat for no reason;
  • Improve handling of dropboxe controls at the bottom of the object inspector;
  • Fix Wordcloud widget on iOS;
  • Label positions not saved on recalculation;
  • Fix Time out when updating document with new data file;
  • Fix an error when renaming new document;
  • Deleting a user from a company does not unassign any licences they have;
  • Spinner doesn't go away after timeout creating new document;
  • Page and its content doesn't show up after copy pasting by dragging in Pages tree;
  • Stacked column chart ignores created columns/columns made as NETs;
  • Difficulty in lining up shapes and images with page borders;
  • Fix an issue that allowed users to set passwords and change email addresses of other users in the same company;
  • Missing data in example project;
  • Dashboard combo box control not shown in Edge;
  • Improved language in "How to see the relationship..." suggestion;
  • Fix resized table not showing at correct size in PDF;
  • Fix cursor jumping in JS Gui Controls editor;
  • Fix Background images loading;
Wednesday, January 17th, 2018

New Features:

  • User can now run long calculations in Displayr, if he keeps his browser opened;
  • User can now insert different shapes to the document;
  • User can now preview items that they selected in the dropboxes;
  • Items are no longer moved to the front when user drags them;
  • Content slots are added to Displayr pages;
  • Insert > Table and Insert > Chart now add an empty blank table/chart to the document;
  • Only Reference Labels are shown for Tables and R Outputs, in Pages tree and Object Inspector;
  • Documents imported to Displayr from Q or Web-Q will preserve their look;
  • In view mode only pages are shown in Pages tree.

Bug fixes:

  • Fix filtering if view mode for R outputs if there are multiple data sets in the document;
  • Fix an issue that prevented variables to be recalculated when document is loaded;
  • Preserve master slide text formating;
  • Correct error message is shown if user tries to delete data set that other data sets, tables, or R outputs refer to;
  • Fix an issue that prevented user specifying transparent font color;
  • Deleted footer no longer re-appears on outputs after data set update;
  • R outputs in View mode correctly update if they depend on other R outputs that are updated on schedule;
  • Improve Displayr performance when new R variables are added to the large document;
  • Renaming data set will correctly update references to its variable in Javascript variables of other data sets;
  • Fix text not appearing in text boxes;
  • Fix permission system for Document Settings page;
  • Other bug fixes.
Friday, December 1st, 2017

Bug fix release.

Tuesday, November 28th, 2017

New Features:

  • When hovering over items in drop boxes you'll get preview for the item.
  • Empty Q table now returns a 0-length R array with a message explaining the problem.
  • IE 8 is no longer supported by Displayr/Web-Q/DataCracker.
  • Rectangle, Oval and arrow shapes can be added to the document.

Bug fixes:

  • Deleted footer no longer re-appears on outputs after data file update.
  • Fix incorrect message boxes about dependencies when deleting a data set.

Known issues:

  • In certain circumstances moving items by dragging them from page to page doesn't work.
  • If you cut the the whole slot and paste it right away it will be pasted over the existing slots.
  • Value attributes window with long list of attributes can becomes unusable.
Friday, November 3rd, 2017

New Features:

  • Displayr better handles htmlwidgets that do not comply with repeated calls to renderValue().
  • Company Admins can review errors that occurred during scheduled R updates.
  • Users can setup Slack notifications for scheduled R updates errors.
  • R calculations can be canceled.

Bug fixes

  • Improved MDD data set loading.
  • View Mode "Filter" menu is no longer active when Explore "folder" is selected.
  • Improved responsiveness of the Account, Settings and Licenses pages.
  • Fixed issues that affected some of the documents in view mode when controls were present on the page.
  • Fixed issue that prevented users in IE9 and below to upload documents on the document settings page.
  • Copy and Pasting group of R output and table doesn't preserve the reference if it is set through R GUI controls
  • Other bug fixes
Thursday, October 5th, 2017

New Features:

  • Large R objects (with serialized size of more than 64Mb) are no longer returned to the client. If one of the outputs of such objects is HTML widget it still be returned.
  • Company admins for multi-user companies can now purchase and manage licences for their company through license tab.
  • Regular users in multi-user companies can now see licenses assigned to them.
  • Multi-user companies have licensing system turned on for them.
  • Company Admins can review invoice email history on Lincenses Tab
  • Empty combo box control in R output now returns NULL
  • HTML widgets can now be exported as data to Excel
  • Filters and on-page controls can affect chains of Analysis Items on the single page. Pages with new calculations can be exported to PowerPoint, Excel and PDF.

Fixed Bugs:

  • Improved MDD data set loading
  • Scheduled R outputs are automatically retried if error was caused by R execution
  • Predictive Tree and Groups/Segments Analysis now allow variables from more than one Data Set
  • Other bug fixes
Tuesday, September 12th 2017
  • You can now switch to a Multi-User Account and purchase licenses for colleagues to edit documents together with you, or give specific people permission to view your documents.
  • Speed improvements for variable sets with many variables.
Wednesday, August 23rd 2017
  • You can now track your Displayr usage through the Usage page.
  • Volume discounts are applied when new licences are purchased.
  • You can restrict view access to your published documents to only people in your company (see Multi-User Account).
  • In view mode selected filters are remembered for individual pages.
  • You have more control over R/JavaScript variables updating, when these types of variables are edited.
  • When you export to PDF and the content of page doesn't fit the page height it will no longer be truncated, but the new page will be created with the overflow displayed on it.
  • Looped questions in IBM .mdd files are now detected better.
  • Text R outputs now have transparent background.
  • You can now create your own tabs in Object Inspector for Standard R outputs.
  • "page:GUID" syntax was deprecated in favour of "#page=GUID".
  • You can now copy paste large items between pages.
Monday, July 10th 2017
  • Resized images embedded into the documents are now exported with correct size and position.
Wednesday, July 5th 2017
  • Zooming in view mode.
  • R Output calculation status icons.
  • Feedback tooltip for previewing variable output for JavaScript and R variables.
Wednesday, June 28th 2017
  • You can now control-click to follow links in edit mode
  • Hyperlinks can be inserted inside text boxes
  • Warning will be displayed while opening document in browsers that do not support TLS 1.2
  • Filters are applied to R Outputs that use them in view mode
  • Bug fixes for combo box control
Monday, June 19th 2017
  • Partial fix for issue with adding new pages and R outputs to the projects with many existing R outputs and R variables.
  • Combo box control related fixes
Tuesday, June 13th 2017
  • You can get a link to a specific page in view mode
  • Combobox controls are now available in Displayr

Earlier releases of Displayr not included here.